summaryrefslogtreecommitdiff
path: root/gnu/packages/mastodon.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-30 23:54:23 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-12-01 00:49:12 +0100
commit11a05344ecde4f39ea11af069f9ea24725235226 (patch)
treefaf63b9c4464417b94d0a527a0647d7a69845e51 /gnu/packages/mastodon.scm
parent27b77228cf06d88b25185124928df0dd43d56b80 (diff)
downloadguix-patches-11a05344ecde4f39ea11af069f9ea24725235226.tar
guix-patches-11a05344ecde4f39ea11af069f9ea24725235226.tar.gz
gnu: toot: Update to 0.24.0.
* gnu/packages/mastodon.scm (toot): Update to 0.24.0. [arguments]: Remove obsolete ‘dont-install-Makefile’ phase.
Diffstat (limited to 'gnu/packages/mastodon.scm')
-rw-r--r--gnu/packages/mastodon.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index cd12f5a7fd..d2370f2527 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,31 +24,23 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages check)
#:use-module (gnu packages python-web)
- #:use-module (gnu packages python-xyz)
-)
+ #:use-module (gnu packages python-xyz))
(define-public toot
(package
(name "toot")
- (version "0.21.0")
+ (version "0.24.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "toot" version))
(sha256
- (base32
- "1dqv5jckaw3r7dnfns3iygwbfnf27x513qrw2rryzl5y79xrzs1x"))))
+ (base32 "0w83b6ydaggrand9285wfrjrm1qry8fjl4as0iihma630ky6y2w3"))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(delete 'check)
- ;; see https://github.com/ihabunek/toot/issues/91
- (add-after 'unpack 'dont-install-Makefile
- (lambda _
- (substitute* "setup.py"
- (("data_files.*" all) ""))
- #t))
(add-after 'install 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)