summaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-02-04 10:26:37 -0300
committerVinicius Monego <monego@posteo.net>2022-02-04 10:29:58 -0300
commitde38ccf2e0bb2fd21393925c296b65dca7499bd3 (patch)
treee8be09127c1aac594203c17748ab9fb554583bb2 /gnu/packages/markup.scm
parent50f95a755c5488a2f5ed3f68c452e1a046e768fa (diff)
downloadguix-patches-de38ccf2e0bb2fd21393925c296b65dca7499bd3.tar
guix-patches-de38ccf2e0bb2fd21393925c296b65dca7499bd3.tar.gz
gnu: python-mistletoe: Run tests.
* gnu/packages/markup.scm (python-mistletoe)[arguments]: Override the 'check phase.
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 06849d05d9..ce131a5835 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2021 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -448,6 +449,13 @@ with a few extensions.")
(sha256
(base32 "0h8ydzxlfzmspiz8lcm13qp720kfsxiky0qqnc2mxf4qzm16m326"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest" "discover" "test")))))))
(home-page "https://github.com/miyuchina/mistletoe")
(synopsis "Extensible Markdown parser in pure Python")
(description