summaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-19 22:47:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-20 10:02:47 +0200
commitd71af69d1b02a304a8c5467bbd5a04e23e16fed0 (patch)
treee064daee0ab4d6b65fe7b950e449b626c695764a /gnu/packages/markup.scm
parent27a3c836e7848bba225c002525fc9b773ed4fef7 (diff)
downloadguix-patches-d71af69d1b02a304a8c5467bbd5a04e23e16fed0.tar
guix-patches-d71af69d1b02a304a8c5467bbd5a04e23e16fed0.tar.gz
gnu: hoedown: Don't use unstable tarball.
* gnu/packages/markup.scm (hoedown)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 6f1f9f6f68..911d929e97 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
@@ -40,13 +40,14 @@
(name "hoedown")
(version "3.0.7")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/hoedown/hoedown/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hoedown/hoedown.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0859dc2xjasd6kgkshi8mb20kbyw5sql1ln0hw3bfaf33qdh5dh1"))))
+ "1kr3hxjg2dgmwy9738qgj3sh3f5cygx0zxskkfhrg7x19bq9yd26"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))