summaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorphodina <phodina@protonmail.com>2021-11-05 05:48:58 +0000
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-11-05 21:36:04 +0100
commit90ab3ef812341b6f031e4724a56c0d7663977be9 (patch)
tree6ba3dcd42cf64d539f5585d6fe94b17633e0929b /gnu/packages/markup.scm
parent3827c66dc1d9760f6f7f4753a518124075f10e64 (diff)
downloadguix-patches-90ab3ef812341b6f031e4724a56c0d7663977be9.tar
guix-patches-90ab3ef812341b6f031e4724a56c0d7663977be9.tar.gz
gnu: Add lowdown.
* gnu/packages/markup.scm (lowdown): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 368976bfde..40b7a3d8c6 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -7,6 +7,8 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
+;;; Copyright © 2021 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +27,7 @@
(define-module (gnu packages markup)
#:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
@@ -34,6 +37,7 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix utils)
+ #:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages)
#:use-module (gnu packages perl)
@@ -114,6 +118,36 @@ convert it to structurally valid XHTML (or HTML).")
(license (non-copyleft "file://License.text"
"See License.text in the distribution."))))
+(define-public lowdown
+ (package
+ (name "lowdown")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://kristaps.bsd.lv/lowdown/snapshots/lowdown-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "15v2kk4ffqw3n6y6n9plch4qcib3ynnhw0ih8wn2v9qgn4jssp5p"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "regress"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "./configure"
+ (string-append "PREFIX=" out)
+ (string-append "MANDIR=" out "/share/man"))))))))
+ (native-inputs
+ `(("which" ,which)))
+ (home-page "https://kristaps.bsd.lv/lowdown/")
+ (synopsis "Simple Markdown translator")
+ (description "Lowdown is a Markdown translator producing HTML5,
+roff documents in the ms and man formats, LaTeX, gemini, and terminal output.")
+ (license license:isc)))
+
(define-public discount
(package
(name "discount")