summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2021-11-21 13:25:22 +0100
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2021-11-21 20:35:40 +0100
commitf33a977706eb2f6dbbce8a515a4f4963a0f0579d (patch)
tree5c745b458e445b95013d16ef36323ac28c14da4b /gnu/packages/man.scm
parent0154fac42a6e3ec6080605af89958b779f536e9d (diff)
downloadguix-patches-f33a977706eb2f6dbbce8a515a4f4963a0f0579d.tar
guix-patches-f33a977706eb2f6dbbce8a515a4f4963a0f0579d.tar.gz
gnu: help2man: Resurrect cross-building.
This is a follow-up to commit 378df42fc5ed85260cd9d4c666b67f29baf11f48 gnu: help2man: Add optional dependencies. It resurrects the cross-building of all build dependencies for guix, e.g., for creating a childhurd with a Guix development environment. * gnu/packages/man.scm (help2man)[inputs]: Do not use perl-gettext when cross-building; perl-gettext cannot be cross-built.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index ca4d3254d5..47c5ae1288 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -336,7 +337,9 @@ Linux kernel and C library interfaces employed by user-space programs.")
#t)))))
(inputs
`(("perl" ,perl)
- ("perl-gettext" ,perl-gettext)))
+ ,@(if (%current-target-system)
+ '()
+ `(("perl-gettext" ,perl-gettext)))))
(native-inputs
`(("perl" ,perl)
("gettext" ,gettext-minimal)))