summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-05-06 23:55:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-05-06 23:55:50 +0200
commitccb15b343e35d76a5c7c693f4c00d3f5b5a4cc39 (patch)
tree10afbd937f70bf7cd458a62a265c149701184a81 /gnu/packages/man.scm
parent021469bc058b0f34d8746bf6e6af132614ec61ee (diff)
downloadguix-patches-ccb15b343e35d76a5c7c693f4c00d3f5b5a4cc39.tar
guix-patches-ccb15b343e35d76a5c7c693f4c00d3f5b5a4cc39.tar.gz
Revert "gnu: man-db: Embed absolute reference to 'preconv'."
This change broke `man` when invoked outside a `guix environment`. This reverts commit 296551a2e9310d4a030ee49530e9367e73aaeecf.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 334ebe2906..ca6fd351d5 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -5,7 +5,6 @@
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -81,19 +80,11 @@ a flexible and convenient way.")
(string-append "#!" (which "sh")))))
(remove file-is-directory?
(find-files "src/tests" ".*"))))))
- (add-after 'unpack 'patch-absolute-paths
+ (add-after 'unpack 'patch-iconv-path
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/man.c"
(("\"iconv\"")
(string-append "\"" (which "iconv") "\"")))
- ;; Embed an absolute reference to "preconv", otherwise it
- ;; falls back to searching in PATH and ultimately fails
- ;; to render unicode data (see <https://bugs.gnu.org/30785>).
- (substitute* "lib/encodings.c"
- (("groff_preconv = NULL")
- (string-append "groff_preconv = \""
- (assoc-ref inputs "groff-minimal")
- "/bin/preconv\"")))
#t)))
#:configure-flags
(let ((groff (assoc-ref %build-inputs "groff"))