summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@member.fsf.org>2014-04-06 20:30:37 -0400
committerDavid Thompson <dthompson@member.fsf.org>2014-04-08 20:42:08 -0400
commitcb3da2339a372bc71e2c678c826bbda0825f27e4 (patch)
tree85b84bb91b727ba3523ef971ca8398cf1149d5ec /gnu/packages/man.scm
parent67ca0a01bb3ffb425f9f6e278ac013987fe304c4 (diff)
downloadguix-patches-cb3da2339a372bc71e2c678c826bbda0825f27e4.tar
guix-patches-cb3da2339a372bc71e2c678c826bbda0825f27e4.tar.gz
gnu: Move help2man package to (gnu packages man) module.
* gnu/packages/man.scm (help2man): New variable. * gnu/packages/help2man.scm: Delete it. * gnu/packages/cdrom.scm: Import (gnu packages man). * gnu/packages/zile.scm: Import (gnu packages man). * gnu-system.am (GNU_SYSTEM_MODULES): Delete 'gnu/packages/help2man.scm'.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index db13fc14a7..9be408a3d1 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
;;;
;;; This file is part of GNU Guix.
@@ -26,6 +27,7 @@
#:use-module (gnu packages groff)
#:use-module (gnu packages less)
#:use-module (gnu packages lynx)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config))
(define-public libpipeline
@@ -107,3 +109,32 @@ a flexible and convenient way.")
accessed using the man command. It uses a Berkeley DB database in place of
the traditional flat-text whatis databases.")
(license gpl2+)))
+
+(define-public help2man
+ (package
+ (name "help2man")
+ (version "1.45.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/help2man/help2man-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1hk7ciqinq7djdb7s94y3jxh06rp8i93bpjmg4r40cniws8wf3y7"))))
+ (build-system gnu-build-system)
+ (arguments `(;; There's no `check' target.
+ #:tests? #f))
+ (inputs
+ `(("perl" ,perl)
+ ;; TODO: Add these optional dependencies.
+ ;; ("perl-LocaleGettext" ,perl-LocaleGettext)
+ ;; ("gettext" ,gnu-gettext)
+ ))
+ (home-page "http://www.gnu.org/software/help2man/")
+ (synopsis "Automatically generate man pages from program --help")
+ (description
+ "GNU help2man is a program that converts the output of standard
+\"--help\" and \"--version\" command-line arguments into a manual page
+automatically.")
+ (license gpl3+)))