summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-09 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-09 02:00:00 +0200
commitca73325d75778ca23770fc6287014b2f0a6eea01 (patch)
tree662cfc6f8db3d4bef84a95ced0c46d01fd58f5da /gnu/packages/man.scm
parentbc435c595f7ad988da37c8c5a62f54956bd873cf (diff)
downloadguix-patches-ca73325d75778ca23770fc6287014b2f0a6eea01.tar
guix-patches-ca73325d75778ca23770fc6287014b2f0a6eea01.tar.gz
gnu: man-pages: Use LIST of arguments.
We're already using a Gexp for #:make-flags; this unweirds that ,#~. * gnu/packages/man.scm (man-pages)[arguments]: Use LIST & G-expressions.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm36
1 files changed, 19 insertions, 17 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 8ecb62dbe2..813ef46e62 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -282,25 +282,27 @@ PostScript, and PDF. Additional tools include the @command{man} viewer, and
(base32 "1252c1356z5spya3yl0lcmmymglx3bmfwmamiz1y5l13xqpwbnwy"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-html
- ;; As of 6.00, this package tries to convert man pages to HTML with
- ;; man2html. The only Guix package currently providing that script
- ;; is man-for-txr, but that version seems unable to handle relative
- ;; ‘.so’ statements properly. Disable HTML generation.
- (lambda _
- (substitute* "lib/build-html.mk"
- (("(html:) .*" _ target) (string-append target "\n")))))
- (delete 'configure))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-html
+ ;; As of 6.00, this package tries to convert man pages to HTML with
+ ;; man2html. The only Guix package currently providing that script
+ ;; is man-for-txr, but that version seems unable to handle relative
+ ;; ‘.so’ statements properly. Disable HTML generation.
+ (lambda _
+ (substitute* "lib/build-html.mk"
+ (("(html:) .*" _ target) (string-append target "\n")))))
+ (delete 'configure))
- ;; The 'all' target depends on three targets that directly populate
- ;; $(MANDIR) based on its current contents. Doing that in parallel
- ;; leads to undefined behavior (see <http://bugs.gnu.org/18701>.)
- #:parallel-build? #f
+ ;; The 'all' target depends on three targets that directly populate
+ ;; $(MANDIR) based on its current contents. Doing that in parallel
+ ;; leads to undefined behavior (see <http://bugs.gnu.org/18701>.)
+ #:parallel-build? #f
- #:tests? #f
- #:make-flags ,#~(list (string-append "mandir=" #$output "/share/man"))))
+ #:tests? #f
+ #:make-flags
+ #~(list (string-append "mandir=" #$output "/share/man"))))
(home-page "https://www.kernel.org/doc/man-pages/")
(synopsis "Development manual pages from the Linux project")
(description