summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/man.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm29
1 files changed, 13 insertions, 16 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 47c5ae1288..53ffc4ac62 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -69,8 +69,7 @@
(modify-phases %standard-phases
(delete 'configure))))
(propagated-inputs
- `(("perl" ,perl)
- ("perl-xml-parser" ,perl-xml-parser)))
+ (list perl perl-xml-parser))
(synopsis "XML to Man converter")
(description "XMLtoMan and XMLMantoHTML are two small scripts to convert xml
to man pages in groff format or html. It features the usual man page items such
@@ -200,18 +199,16 @@ a flexible and convenient way.")
(guix build utils)
(srfi srfi-1))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("flex" ,flex)
- ("groff" ,groff))) ;needed at build time (troff, grops, soelim, etc.)
+ (list pkg-config flex groff)) ;needed at build time (troff, grops, soelim, etc.)
(inputs
- `(("gdbm" ,gdbm)
- ("groff-minimal" ,groff-minimal)
- ("less" ,less)
- ("libpipeline" ,libpipeline)
- ;; FIXME: 4.8 and later can use libseccomp, but it causes test
- ;; failures in the build chroot.
- ;;("libseccomp" ,libseccomp)
- ("util-linux" ,util-linux)))
+ (list gdbm
+ groff-minimal
+ less
+ libpipeline
+ ;; FIXME: 4.8 and later can use libseccomp, but it causes test
+ ;; failures in the build chroot.
+ ;;("libseccomp" ,libseccomp)
+ util-linux))
(native-search-paths
(list (search-path-specification
(variable "MANPATH")
@@ -254,8 +251,8 @@ the traditional flat-text whatis databases.")
(("^PREFIX=.*")
(string-append "PREFIX=" (assoc-ref outputs "out")
"\n"))))))))
- (native-inputs `(("perl" ,perl))) ;used to run tests
- (inputs `(("zlib" ,zlib)))
+ (native-inputs (list perl)) ;used to run tests
+ (inputs (list zlib))
(native-search-paths
(list (search-path-specification
(variable "MANPATH")
@@ -399,7 +396,7 @@ in C99.")
#:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out")))
#:phases (modify-phases %standard-phases (delete 'configure))))
(inputs
- `(("gawk" ,gawk)))
+ (list gawk))
(home-page "https://github.com/mvertes/txt2man")
(synopsis "Convert text to man page")
(description "Txt2man converts flat ASCII text to man page format.")