summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorMilkey Mouse <milkeymouse@meme.institute>2021-09-01 16:58:53 -0700
committerLudovic Courtès <ludo@gnu.org>2021-09-07 16:06:41 +0200
commit3d42aa33da54e9a289112afc4ad4662b9402b2f4 (patch)
treec3b1ada7164a413f23fa10c903d66064cac821c2 /gnu/packages/man.scm
parent7865973ef73ca6f634d68b20e18c28a5ea407fbe (diff)
downloadguix-patches-3d42aa33da54e9a289112afc4ad4662b9402b2f4.tar
guix-patches-3d42aa33da54e9a289112afc4ad4662b9402b2f4.tar.gz
gnu: mandoc: Add $MANPATH to native-search-paths.
* gnu/packages/man.scm (mandoc)[native-search-paths]: New field. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 50295b55f7..49e149128d 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -254,6 +254,10 @@ the traditional flat-text whatis databases.")
"\n"))))))))
(native-inputs `(("perl" ,perl))) ;used to run tests
(inputs `(("zlib" ,zlib)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "MANPATH")
+ (files '("share/man")))))
(synopsis "Tools for BSD mdoc and man pages")
(description
"mandoc is a suite of tools compiling mdoc, the roff macro language of