summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorMiguel Ángel Arruga Vivas <rosen644835@gmail.com>2020-12-11 23:46:58 +0100
committerMiguel Ángel Arruga Vivas <rosen644835@gmail.com>2021-01-06 17:14:44 +0100
commit378df42fc5ed85260cd9d4c666b67f29baf11f48 (patch)
tree80b20f03bb755482fe54a1c0dfe05262e5bc57c3 /gnu/packages/man.scm
parent4343ca8ba5b02c8fe09e5bd681abbc0440ab8b08 (diff)
downloadguix-patches-378df42fc5ed85260cd9d4c666b67f29baf11f48.tar
guix-patches-378df42fc5ed85260cd9d4c666b67f29baf11f48.tar.gz
gnu: help2man: Add optional dependencies.
* gnu/packages/man.scm (help2man)[inputs]: Add perl-gettext and gettext-minimal to the inputs.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm23
1 files changed, 17 insertions, 6 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 0eadd9d153..43f503e39c 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -34,6 +34,7 @@
#:use-module (gnu packages dbm)
#:use-module (gnu packages flex)
#:use-module (gnu packages gawk)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages groff)
#:use-module (gnu packages less)
#:use-module (gnu packages perl)
@@ -257,6 +258,8 @@ Linux kernel and C library interfaces employed by user-space programs.")
(license license:gpl2+)))
(define-public help2man
+ ;; TODO: Manual pages for languages not available from the implicit
+ ;; input "locales" contain the original (English) text.
(package
(name "help2man")
(version "1.47.13")
@@ -270,15 +273,23 @@ Linux kernel and C library interfaces employed by user-space programs.")
"08q5arxz4j4pyx5q4712c2rn7p7dw7as9xg38yvmsh1c3ynvpy5p"))))
(build-system gnu-build-system)
(arguments `(;; There's no `check' target.
- #:tests? #f))
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-help2man-with-perl-gettext
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((lib (assoc-ref inputs "perl-gettext"))
+ (fmt "use lib '~a/lib/perl5/site_perl';~%~a"))
+ (substitute* "help2man.PL"
+ (("^use Locale::gettext.*$" load)
+ (format #f fmt lib load))))
+ #t)))))
(inputs
`(("perl" ,perl)
- ;; TODO: Add these optional dependencies.
- ;; ("perl-LocaleGettext" ,perl-LocaleGettext)
- ;; ("gettext" ,gettext-minimal)
- ))
+ ("perl-gettext" ,perl-gettext)))
(native-inputs
- `(("perl" ,perl)))
+ `(("perl" ,perl)
+ ("gettext" ,gettext-minimal)))
(home-page "https://www.gnu.org/software/help2man/")
(synopsis "Automatically generate man pages from program --help")
(description