summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-12 23:15:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-08 09:28:38 +0300
commitf819b46acb497f7c1f1cd261f03a5714738b7110 (patch)
tree9f9244356c217769d60c1b460b88ac7d5102ab0a /gnu/packages/make-bootstrap.scm
parent4cbe0127a668cbcc64087c5d311308b59d39b104 (diff)
downloadguix-patches-f819b46acb497f7c1f1cd261f03a5714738b7110.tar
guix-patches-f819b46acb497f7c1f1cd261f03a5714738b7110.tar.gz
gnu: make-bootstrap: Build with gcc-7.
* gnu/packages/make-bootstrap.scm (gcc-for-bootstrap)[Inherit]: Inherit from gcc-7. [inputs]: Use package-inputs from gcc-7. (package-with-relocatable-glibc)[native-inputs]: Have cross-gcc use gcc-7. (%gcc-static)[inherit]: Inherit from gcc-7. [arguments]: Use package-arguments from gcc-7. [inputs]: Replace isl-0.18 with isl. Use package-inputs from gcc-7. [native-inputs]: Use package-native-inputs from gcc-7. (%gcc-stripped)[inherit]: Inherit from gcc-7.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index bf76d5052f..ff9376e91f 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018, 2019, 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
@@ -94,13 +94,13 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(mlambdaq (glibc)
"Return a variant of GCC that uses the bootstrap variant of GLIBC."
(package
- (inherit gcc-5)
+ (inherit gcc-7)
(outputs '("out")) ;all in one so libgcc_s is easily found
(inputs
`( ;; Distinguish the name so we can refer to it below.
("bootstrap-libc" ,(glibc-for-bootstrap glibc))
("libc:static" ,(glibc-for-bootstrap glibc) "static")
- ,@(package-inputs gcc-5))))))
+ ,@(package-inputs gcc-7))))))
(define (package-with-relocatable-glibc p)
"Return a variant of P that uses the libc as defined by
@@ -139,7 +139,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(cons (search-path-specification
(variable "CROSS_CPLUS_INCLUDE_PATH")
(files '("include")))
- (package-search-paths gcc-5)))))
+ (package-search-paths gcc-7)))))
("cross-binutils" ,(cross-binutils target))
,@(%final-inputs)))
`(("libc" ,(glibc-for-bootstrap glibc))
@@ -461,11 +461,11 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(define %gcc-static
;; A statically-linked GCC, with stripped-down functionality.
(package-with-relocatable-glibc
- (package (inherit gcc-5)
+ (package (inherit gcc-7)
(name "gcc-static")
(outputs '("out")) ; all in one
(arguments
- (substitute-keyword-arguments (package-arguments gcc-5)
+ (substitute-keyword-arguments (package-arguments gcc-7)
((#:modules modules %gnu-build-system-modules)
`((srfi srfi-1)
(srfi srfi-26)
@@ -515,8 +515,8 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
#t))))))
(inputs
`(("zlib:static" ,zlib "static")
- ("isl:static" ,isl-0.18 "static")
- ,@(package-inputs gcc-5)))
+ ("isl:static" ,isl "static")
+ ,@(package-inputs gcc-7)))
(native-inputs
(if (%current-target-system)
`(;; When doing a Canadian cross, we need GMP/MPFR/MPC both
@@ -529,12 +529,12 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
("gmp-native" ,gmp)
("mpfr-native" ,mpfr)
("mpc-native" ,mpc)
- ,@(package-native-inputs gcc-5))
- (package-native-inputs gcc-5))))))
+ ,@(package-native-inputs gcc-7))
+ (package-native-inputs gcc-7))))))
(define %gcc-stripped
;; The subset of GCC files needed for bootstrap.
- (package (inherit gcc-5)
+ (package (inherit gcc-7)
(name "gcc-stripped")
(build-system trivial-build-system)
(source #f)