summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-15 23:42:58 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-15 23:42:58 +0200
commitdfb52abbd60876de250f04fc5c64b3c85082cba6 (patch)
tree1ba75d6d5d217253dcb161a8dbf1387199ae577b /gnu/packages/make-bootstrap.scm
parent59fbeb8cae02032a2f8b7966ab52545817f3ed88 (diff)
downloadguix-patches-dfb52abbd60876de250f04fc5c64b3c85082cba6.tar
guix-patches-dfb52abbd60876de250f04fc5c64b3c85082cba6.tar.gz
Remove weirdnesses caused by 'letrec*' behavior of record field initializers.
* gnu/packages/bootstrap.scm (package-from-tarball): Remove '*' from parameter names. Adjust accordingly. * gnu/packages/linux-initrd.scm (expression->initrd): Use 'name' directly, removing the 'name*' alias. * gnu/packages/linux.scm (linux-libre-headers, linux-libre): Rename 'version*' to 'version'.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 5dc7387e92..8c148f7086 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -451,15 +451,15 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; A statically-linked Guile that is relocatable--i.e., it can search
;; .scm and .go files relative to its installation directory, rather
;; than in hard-coded configure-time paths.
- (let* ((patches* (cons* (search-patch "guile-relocatable.patch")
- (search-patch "guile-default-utf8.patch")
- (search-patch "guile-linux-syscalls.patch")
- (origin-patches (package-source guile-2.0))))
- (source* (origin (inherit (package-source guile-2.0))
- (patches patches*)))
+ (let* ((patches (cons* (search-patch "guile-relocatable.patch")
+ (search-patch "guile-default-utf8.patch")
+ (search-patch "guile-linux-syscalls.patch")
+ (origin-patches (package-source guile-2.0))))
+ (source (origin (inherit (package-source guile-2.0))
+ (patches patches)))
(guile (package (inherit guile-2.0)
(name (string-append (package-name guile-2.0) "-static"))
- (source source*)
+ (source source)
(synopsis "Statically-linked and relocatable Guile")
(propagated-inputs
`(("bdw-gc" ,libgc)