summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2018-11-20 08:12:09 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2018-11-24 08:17:20 +0100
commitda91723cc5bba433f59ac40ee669d97e4cbc0e45 (patch)
treed5af69ff725fca02f39bd8d24fe3b323c8314ec5 /gnu/packages/make-bootstrap.scm
parentd9ed0a46301e259c3082fcc67678e72ceae19a2d (diff)
downloadguix-patches-da91723cc5bba433f59ac40ee669d97e4cbc0e45.tar
guix-patches-da91723cc5bba433f59ac40ee669d97e4cbc0e45.tar.gz
bootstrap: Force i686-linux for bootstrap-tarballs.
* gnu/packages/make-bootstrap.scm (%mescc-tools-static): Force i686-linux for bootstrap-tarballs. (%mes-minimal): Likewise. Remove i686-linux cross-compiler dependency. * gnu/packages/commencement.scm (mes-boot): Support strict i686-linux build on x86_64.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index fa3914cde7..761420af67 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -542,9 +542,10 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(inherit mescc-tools)
(name "mescc-tools-static")
(arguments
- (substitute-keyword-arguments (package-arguments mescc-tools)
- ((#:make-flags flags)
- `(cons "CC=gcc -static" ,flags))))))
+ `(#:system "i686-linux"
+ ,@(substitute-keyword-arguments (package-arguments mescc-tools)
+ ((#:make-flags flags)
+ `(cons "CC=gcc -static" ,flags)))))))
(define %mes-minimal
;; A minimal Mes without documentation dependencies, for bootstrap.
@@ -553,16 +554,10 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(inherit mes)
(name "mes-minimal")
(native-inputs
- `(("guile" ,guile-2.2)
- ,@(if (not (string-prefix? "i686-linux" (or (%current-target-system)
- (%current-system))))
- ;; Use cross-compiler rather than #:system "i686-linux" to get
- ;; MesCC 64 bit .go files installed ready for use with Guile.
- `(("i686-linux-binutils" ,(cross-binutils triplet))
- ("i686-linux-gcc" ,(cross-gcc triplet)))
- '())))
+ `(("guile" ,guile-2.2)))
(arguments
- `(#:strip-binaries? #f
+ `(#:system "i686-linux"
+ #:strip-binaries? #f
#:phases
(modify-phases %standard-phases
(add-before 'configure 'optional-dot