summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-29 22:20:46 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-30 00:06:30 +0200
commitda8be73d5bd85e7fd256a23f94c5f752c796dcac (patch)
tree3ed3f31cc3aabbe8a382201c39b7c99f4a605f00 /gnu/packages/make-bootstrap.scm
parent191c1992b819e9489054a1f2d8d300bfef2fe6f2 (diff)
downloadguix-patches-da8be73d5bd85e7fd256a23f94c5f752c796dcac.tar
guix-patches-da8be73d5bd85e7fd256a23f94c5f752c796dcac.tar.gz
gnu: guile-static: Disable JIT on GNU/Hurd.
* gnu/packages/make-bootstrap.scm (make-guile-static): Pass "--disable-jit" when targeting GNU/Hurd.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 2a00ab1d2f..0014783b4a 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -699,8 +699,10 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; When `configure' checks for ltdl availability, it
;; doesn't try to link using libtool, and thus fails
;; because of a missing -ldl. Work around that.
- ''("LDFLAGS=-ldl"
- "--enable-mini-gmp"))
+ `(list "LDFLAGS=-ldl" "--enable-mini-gmp"
+ ,@(if (hurd-target?)
+ '("--disable-jit")
+ '())))
((#:phases phases '%standard-phases)
`(modify-phases ,phases