summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-02 22:28:30 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-02 22:28:30 +0100
commitc9323eac746e1905f9cacf17408a5678c2bdefbf (patch)
tree8830821c95fa533c6730f9458873a69efb00bce7 /gnu/packages/make-bootstrap.scm
parent55a5674f21d1adf4a8b2d0c67f6a6ba51ebb4027 (diff)
downloadguix-patches-c9323eac746e1905f9cacf17408a5678c2bdefbf.tar
guix-patches-c9323eac746e1905f9cacf17408a5678c2bdefbf.tar.gz
gnu: make-bootstrap: Allow bit-reproducibility for 'glibc-stripped'.
* gnu/packages/make-bootstrap.scm (%glibc-stripped): Remove '.install' and '..install.cmd' files.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index c79bcc2cf3..2630ad5ce0 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -363,6 +363,11 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(string-append incdir "/asm"))
(copy-recursively (string-append linux "/include/asm-generic")
(string-append incdir "/asm-generic"))
+
+ ;; Remove the '.install' and '..install.cmd' files; the latter
+ ;; contains store paths, which prevents bit reproducibility.
+ (for-each delete-file (find-files incdir "\\.install"))
+
#t))))
(inputs `(("libc" ,(let ((target (%current-target-system)))
(if target