summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 06:31:22 -0400
committerMark H Weaver <mhw@netris.org>2018-03-16 06:44:22 -0400
commitc2af3b0725a25daa0b66a9943334ed997478b985 (patch)
tree3e42430209e98bbbad59a03bb56c7c33741ac4b2 /gnu/packages/make-bootstrap.scm
parentd70d59d6f44d50d074089e91d457b9dac330bdd6 (diff)
downloadguix-patches-c2af3b0725a25daa0b66a9943334ed997478b985.tar
guix-patches-c2af3b0725a25daa0b66a9943334ed997478b985.tar.gz
gnu: gcc-stripped: Use invoke instead of system*.
* gnu/packages/make-bootstrap.scm (gcc-stripped)[arguments]: Use invoke. All phases return #t.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index e779376df9..eaef4c89c2 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -494,12 +495,14 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(string-append includedir "/c++"))
;; For native builds, check whether the binaries actually work.
- ,(if (%current-target-system)
- '#t
- '(every (lambda (prog)
- (zero? (system* (string-append gcc "/bin/" prog)
- "--version")))
- '("gcc" "g++" "cpp")))))))
+ ,@(if (%current-target-system)
+ '()
+ '((for-each (lambda (prog)
+ (invoke (string-append gcc "/bin/" prog)
+ "--version"))
+ '("gcc" "g++" "cpp"))))
+
+ #t))))
(inputs `(("gcc" ,%gcc-static)))))
(define %guile-static