summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-05-27 23:57:41 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-06 23:28:49 +0200
commitb2ee53d5aead4e2c49f526c8ddcf5a279e879236 (patch)
tree492f010edef925a9b9d2000496138885bd89ada5 /gnu/packages/make-bootstrap.scm
parente768e4e97fff4615da01245437ee91f27adb0c9c (diff)
downloadguix-patches-b2ee53d5aead4e2c49f526c8ddcf5a279e879236.tar
guix-patches-b2ee53d5aead4e2c49f526c8ddcf5a279e879236.tar.gz
gnu: guile-static: Disable JIT on ARMv7.
* gnu/packages/make-bootstrap.scm (make-guile-static): Pass "--disable-jit" when 'target-arm32?' is true.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index fe86f810bf..b2d3e2a326 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -706,7 +706,12 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; When `configure' checks for ltdl availability, it
;; doesn't try to link using libtool, and thus fails
;; because of a missing -ldl. Work around that.
- ''("LDFLAGS=-ldl"))
+
+ ;; XXX: On ARMv7, disable JIT: it causes crashes with 3.0.2,
+ ;; possibly related to <https://bugs.gnu.org/40737>.
+ (if (target-arm32?)
+ ''("LDFLAGS=-ldl" "--disable-jit")
+ ''("LDFLAGS=-ldl")))
((#:phases phases '%standard-phases)
`(modify-phases ,phases