summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-04 14:37:53 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-04 14:37:53 +0200
commitb15389e15958dcfdd6a321ab635233b74b9ea630 (patch)
tree741a5ce390bb3915a7dca3c52ed8343ded5cd111 /gnu/packages/make-bootstrap.scm
parent67dfa1986d7e8af9a42ffa7c9d2b40599857cf19 (diff)
downloadguix-patches-b15389e15958dcfdd6a321ab635233b74b9ea630.tar
guix-patches-b15389e15958dcfdd6a321ab635233b74b9ea630.tar.gz
gnu: linux-libre-headers: Do not retain reference to the bootstrap tools.
* gnu/packages/linux.scm (linux-libre-headers)[install-phase]: Remove ".install" files from the output. [arguments]: Add #:allowed-references.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 88fad0e604..9eb868a118 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -374,10 +374,6 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(copy-recursively (string-append linux "/include/asm-generic")
(string-append incdir "/asm-generic"))
- ;; Remove the '.install' and '..install.cmd' files; the latter
- ;; contains store paths, which prevents bit reproducibility.
- (for-each delete-file (find-files incdir "\\.install"))
-
#t))))
(inputs `(("libc" ,(let ((target (%current-target-system)))
(if target