summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-02-03 16:24:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-02-17 12:45:31 +0200
commitb05fa64fcf262fc6f3c936f237e88f850d9cabe1 (patch)
tree8373456e2ec454e7bf0619417f569291fe1e52c6 /gnu/packages/make-bootstrap.scm
parentac16cf3ece815d02c708cc00da958cf52e158ba6 (diff)
downloadguix-patches-b05fa64fcf262fc6f3c936f237e88f850d9cabe1.tar
guix-patches-b05fa64fcf262fc6f3c936f237e88f850d9cabe1.tar.gz
gnu: %static-inputs: Use 'grep' without custom phase.
This reverts commit 1063d325ea76aa2b00dfcd3d436b16e412103df1 for during creation of the bootstrap-binaries. * gnu/packages/make-bootstrap.scm (%static-inputs): Use a custom 'grep' without the absolute path name in fgrep/egrep.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index d2a559c084..5cc2ac51d9 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -206,7 +207,17 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
("patch" ,patch)
("coreutils" ,coreutils)
("sed" ,sed)
- ("grep" ,grep)
+ ;; We don't want to retain a reference to /gnu/store in the
+ ;; bootstrap versions of egrep/fgrep, so we remove the custom
+ ;; phase added since grep@2.25. The effect is 'egrep' and
+ ;; 'fgrep' look for 'grep' in $PATH.
+ ("grep" ,(package
+ (inherit grep)
+ (arguments
+ (substitute-keyword-arguments (package-arguments grep)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (delete 'fix-egrep-and-fgrep)))))))
("gawk" ,gawk)))
("bash" ,static-bash))))