summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-09 22:28:04 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-09 23:04:14 +0100
commit929c365ad02a50a6b612866d7700e01e62e3fdd6 (patch)
tree7b78bb399374981a9bd0fbb2c242fdf80e94eb7f /gnu/packages/make-bootstrap.scm
parent0c72a719efee667c7d3eba1c74c357838fc84efa (diff)
downloadguix-patches-929c365ad02a50a6b612866d7700e01e62e3fdd6.tar
guix-patches-929c365ad02a50a6b612866d7700e01e62e3fdd6.tar.gz
gnu: make-bootstrap: Slightly clarify 'package-with-relocatable-glibc'.
* gnu/packages/make-bootstrap.scm (package-with-relocatable-glibc) [cross-bootstrap-libc]: Take an explicit 'target' argument. Remove redundant 'parameterize' form. [inputs, native-inputs]: Adjust accordingly.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 4e6be3270a..b8d1b2af3e 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -125,19 +125,19 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
"Return a variant of P that uses the libc as defined by
`glibc-for-bootstrap'."
- (define (cross-bootstrap-libc)
- (let ((target (%current-target-system)))
- (glibc-for-bootstrap
- ;; `cross-libc' already returns a cross libc, so clear
- ;; %CURRENT-TARGET-SYSTEM.
- (parameterize ((%current-target-system #f))
- (cross-libc target)))))
+ (define (cross-bootstrap-libc target)
+ (glibc-for-bootstrap
+ ;; `cross-libc' already returns a cross libc, so clear
+ ;; %CURRENT-TARGET-SYSTEM.
+ (parameterize ((%current-target-system #f))
+ (cross-libc target))))
;; Standard inputs with the above libc and corresponding GCC.
(define (inputs)
(if (%current-target-system) ; is this package cross built?
- `(("cross-libc" ,(cross-bootstrap-libc)))
+ `(("cross-libc"
+ ,(cross-bootstrap-libc (%current-target-system))))
'()))
(define (native-inputs)
@@ -146,7 +146,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(xgcc (cross-gcc
target
#:xbinutils (cross-binutils target)
- #:libc (cross-bootstrap-libc))))
+ #:libc (cross-bootstrap-libc target))))
`(("cross-gcc" ,(package
(inherit xgcc)
(search-paths