summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-01-03 15:20:18 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2020-01-16 10:15:12 +0100
commit8bd2b15b06f6306e37cc72995b76a7f0754cf1a6 (patch)
tree9fae0c874ad13976cfd64ee17976b509abf7230c /gnu/packages/make-bootstrap.scm
parentaded68b30083d2042c543c0a1d7685b2147c2b83 (diff)
downloadguix-patches-8bd2b15b06f6306e37cc72995b76a7f0754cf1a6.tar
guix-patches-8bd2b15b06f6306e37cc72995b76a7f0754cf1a6.tar.gz
gnu: make-bootstrap: Add cross-libc:static to the inputs.
This is a follow-up of 4610ab7c9a5327df0d475262817bc081a5891aa8. 'getpw' & co fail with a cross-compiled statically-linked guile. * gnu/packages/make-bootstrap.scm (package-with-relocatable-glibc)[inputs]: Add "cross-libc:static".
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index d149a7ec1a..0144a6e9a2 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018, 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018, 2019 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -137,7 +138,10 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(define (inputs)
(if (%current-target-system) ; is this package cross built?
`(("cross-libc"
- ,(cross-bootstrap-libc (%current-target-system))))
+ ,(cross-bootstrap-libc (%current-target-system)))
+ ("cross-libc:static"
+ ,(cross-bootstrap-libc (%current-target-system))
+ "static"))
'()))
(define (native-inputs)