summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-25 20:15:45 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-26 13:24:23 +0200
commit8b627a77014bc64bae2481fceeb28bcd61035b5b (patch)
tree6f0e4351ccc414df2a95058b7f18daacba532304 /gnu/packages/make-bootstrap.scm
parent0236013cd0fc86ff4a042885c735e3f36a7f5c25 (diff)
downloadguix-patches-8b627a77014bc64bae2481fceeb28bcd61035b5b.tar
guix-patches-8b627a77014bc64bae2481fceeb28bcd61035b5b.tar.gz
gnu: mes-minimal: Remove unused variable.
* gnu/packages/make-bootstrap.scm (%mes-minimal): Remove unused 'triplet' variable.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm49
1 files changed, 24 insertions, 25 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 60b6f1b42e..32542f6da7 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -623,31 +623,30 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; Two packages: first build static, bare minimum content.
(define-public %mes-minimal
;; A minimal Mes without documentation.
- (let ((triplet "i686-unknown-linux-gnu"))
- (package
- (inherit mes-0.19)
- (name "mes-minimal")
- (native-inputs
- `(("guile" ,guile-2.2)))
- (arguments
- `(#:system "i686-linux"
- #:strip-binaries? #f
- #:configure-flags '("--mes")
- #:phases
- (modify-phases %standard-phases
- (delete 'patch-shebangs)
- (add-after 'install 'strip-install
- (lambda _
- (let* ((out (assoc-ref %outputs "out"))
- (share (string-append out "/share")))
- (delete-file-recursively (string-append out "/lib/guile"))
- (delete-file-recursively (string-append share "/guile"))
- (delete-file-recursively (string-append share "/mes/scaffold"))
-
- (for-each delete-file
- (find-files
- (string-append share "/mes/lib")
- "\\.(h|c)")))))))))))
+ (package
+ (inherit mes-0.19)
+ (name "mes-minimal")
+ (native-inputs
+ `(("guile" ,guile-2.2)))
+ (arguments
+ `(#:system "i686-linux"
+ #:strip-binaries? #f
+ #:configure-flags '("--mes")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'patch-shebangs)
+ (add-after 'install 'strip-install
+ (lambda _
+ (let* ((out (assoc-ref %outputs "out"))
+ (share (string-append out "/share")))
+ (delete-file-recursively (string-append out "/lib/guile"))
+ (delete-file-recursively (string-append share "/guile"))
+ (delete-file-recursively (string-append share "/mes/scaffold"))
+
+ (for-each delete-file
+ (find-files
+ (string-append share "/mes/lib")
+ "\\.(h|c)"))))))))))
;; next remove store references.
(define %mes-minimal-stripped