summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-09 11:58:43 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-09 11:58:43 +0200
commit84e6756c5734cdfbb79f3b771e8d8fc8f773a795 (patch)
tree38489ffb2d18d1f493aff3fd919f8c94994f5c02 /gnu/packages/make-bootstrap.scm
parente0a0c84b4f1f1c78cdb444193654471c4971b63a (diff)
downloadguix-patches-84e6756c5734cdfbb79f3b771e8d8fc8f773a795.tar
guix-patches-84e6756c5734cdfbb79f3b771e8d8fc8f773a795.tar.gz
gnu: gcc: Add a "lib" output.
* gnu/packages/gcc.scm (gcc-4.7)[configure-flags]: Add --with-gxx-include-dir. [outputs]: New field. [arguments] <phases>: Adjust to use the "lib" output. Add 'substitute*' calls for "libstdc++-v3/python/Makefile.in" and "gcc/config.in". * gnu/packages/base.scm (gcc-boot0) <symlink-libgcc_eh>: Use the "lib" output. (cross-gcc-wrapper): Add 'outputs' field. (glibc-final)[arguments]: Adjust #:allowed-references to list '(GCC-BOOT0 "lib"). (libstdc++): Add 'outputs' field. (gcc-final)[arguments]: Add "lib" to #:allowed-references. * gnu/packages/make-bootstrap.scm (%gcc-static): Add 'outputs' field.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 2e3e9ec4c1..a6079553cc 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -393,6 +393,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(package-with-relocatable-glibc
(package (inherit gcc-4.8)
(name "gcc-static")
+ (outputs '("out")) ; all in one
(arguments
`(#:modules ((guix build utils)
(guix build gnu-build-system)