summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorCarlos Sánchez de La Lama <csanchezdll@gmail.com>2016-10-18 17:55:55 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-19 23:20:19 +0200
commit80c9164fd7741e3bb3da368666f41c49a456d990 (patch)
treef8976d0146dd74b81d7871ae059f8ab1558db319 /gnu/packages/make-bootstrap.scm
parentc21b1a1fbb8c1b776cf831d24dfb1a742a4ded70 (diff)
downloadguix-patches-80c9164fd7741e3bb3da368666f41c49a456d990.tar
guix-patches-80c9164fd7741e3bb3da368666f41c49a456d990.tar.gz
gnu: %static-inputs: Use bash from PATH in bootstrap tar.
gnu/packages/make-bootstrap.scm (%static-inputs): Use bash from PATH. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index def9c23b17..336ad2ee13 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -186,6 +186,17 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(inputs (if (%current-target-system)
`(("bash" ,%bash-static))
'()))))
+ (tar (package (inherit tar)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'build 'set-shell-file-name
+ (lambda _
+ ;; Do not use "/bin/sh" to run programs; see
+ ;; <http://lists.gnu.org/archive/html/guix-devel/2016-09/msg02272.html>.
+ (substitute* "src/system.c"
+ (("/bin/sh") "sh")
+ (("execv ") "execvp "))
+ #t)))))))
(finalize (compose static-package
package-with-relocatable-glibc)))
`(,@(map (match-lambda