summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-08-21 11:44:16 +0200
committerLudovic Courtès <ludo@gnu.org>2013-08-21 11:44:16 +0200
commit75ca2f4f473fec64cd01486e565341430ee2e138 (patch)
treeb2fb71e86b4ce2bf82ead91176bbefc5cbb02942 /gnu/packages/make-bootstrap.scm
parent3e8f16ba9141e2049cefcd80461b60f2385db892 (diff)
downloadguix-patches-75ca2f4f473fec64cd01486e565341430ee2e138.tar
guix-patches-75ca2f4f473fec64cd01486e565341430ee2e138.tar.gz
gnu: make-bootstrap: Add a couple of synopses.
* gnu/packages/make-bootstrap.scm (%guile-static, %guile-static-stripped): Add synopsis.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 7eb3567f25..6f33c07e58 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -451,6 +451,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; than in hard-coded configure-time paths.
(let* ((guile (package (inherit guile-2.0)
(name (string-append (package-name guile-2.0) "-static"))
+ (synopsis "Statically-linked and relocatable Guile")
(inputs
`(("patch/relocatable"
,(search-patch "guile-relocatable.patch"))
@@ -542,7 +543,8 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
#t
'(zero? (system* guile2 "--version")))))))))
(inputs `(("guile" ,%guile-static)))
- (outputs '("out"))))
+ (outputs '("out"))
+ (synopsis "Minimal statically-linked and relocatable Guile")))
(define (tarball-package pkg)
"Return a package containing a tarball of PKG."