summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2017-01-02 21:07:59 +0200
committerManolis Ragkousis <manolis837@gmail.com>2017-01-03 16:00:39 +0200
commit62596a158b4878e3f4b64f3e0f3a3f846228afd4 (patch)
treeaba9fdbf72f5ea1806285d561bbe71c1b1a42cb5 /gnu/packages/make-bootstrap.scm
parent6a37872cd2c132371ef2cb5344e004c63fdeb927 (diff)
downloadguix-patches-62596a158b4878e3f4b64f3e0f3a3f846228afd4.tar
guix-patches-62596a158b4878e3f4b64f3e0f3a3f846228afd4.tar.gz
gnu: Use hurd-triplet? to check if GNU/Hurd.
* gnu/packages/make-bootstrap.scm (hurd-triplet?): Move it from here.. * gnu/packages/hurd.scm: ..to here. New exported procedure. * gnu/packages/commencement.scm (glibc-final-with-bootstrap-bash) [arguments]: Replace string-match. [inputs]: Same. * gnu/packages/cross-base.scm (cross-libc)[native-inputs]: Same.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm4
1 files changed, 0 insertions, 4 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 44a7fd3a16..e5c614cee7 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -337,10 +337,6 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; GNU libc's essential shared libraries, dynamic linker, and headers,
;; with all references to store directories stripped. As a result,
;; libc.so is unusable and need to be patched for proper relocation.
- (define (hurd-triplet? triplet)
- (and (string-suffix? "-gnu" triplet)
- (not (string-contains triplet "linux"))))
-
(let ((glibc (glibc-for-bootstrap)))
(package (inherit glibc)
(name "glibc-stripped")