summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-08 09:39:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-08 09:39:05 +0300
commit49e2e75ced01a821c84eb776cf42a36664eaa834 (patch)
treea077a70446fc1070d483a021e97ac59f77dcf7ac /gnu/packages/make-bootstrap.scm
parente48cff0965207c1abe2d6a71bd1277d8cc46e7c7 (diff)
downloadguix-patches-49e2e75ced01a821c84eb776cf42a36664eaa834.tar
guix-patches-49e2e75ced01a821c84eb776cf42a36664eaa834.tar.gz
gnu: %guile-3.0-static-stripped: Rename to %guile-static-stripped.
* gnu/packages/make-bootstrap.scm (%guile-3.0-static-stripped): Rename to %guile-static-stripped. (%guile-bootstrap-tarball): Adjust accordingly. * gnu/system/linux-initrd.scm (expression->initrd): Use %guile-static-stripped as default guile. * doc/guix.texi (initial RAM disk)[expression->initrd]: Adjust documentation accordingly.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index d66acc2e70..cdcb1dcaa2 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -55,7 +55,7 @@
%mes-bootstrap-tarball
%bootstrap-tarballs
- %guile-3.0-static-stripped))
+ %guile-static-stripped))
;;; Commentary:
;;;
@@ -798,7 +798,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(outputs '("out"))
(synopsis "Minimal statically-linked and relocatable Guile")))
-(define %guile-3.0-static-stripped
+(define %guile-static-stripped
;; A stripped static Guile 3.0 binary, for use in initrds
;; and during bootstrap.
(make-guile-static-stripped
@@ -863,7 +863,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(define %guile-bootstrap-tarball
;; A tarball with the statically-linked, relocatable Guile.
- (tarball-package %guile-3.0-static-stripped))
+ (tarball-package %guile-static-stripped))
(define %mescc-tools-bootstrap-tarball
;; A tarball with statically-linked MesCC binary seed.