summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2021-11-27 01:18:06 +0000
committerPierre Langlois <pierre.langlois@gmx.com>2021-11-27 14:23:30 +0000
commit48b754553aeb98660fe145633616a9d965fbd60e (patch)
treef36e403eda0f481233b2ef5de702868650d03c92 /gnu/packages/make-bootstrap.scm
parent0c7d3243393deedd85b471012fc543421c3e7671 (diff)
downloadguix-patches-48b754553aeb98660fe145633616a9d965fbd60e.tar
guix-patches-48b754553aeb98660fe145633616a9d965fbd60e.tar.gz
gnu: glibc-for-bootstrap: Build with GCC 7.
Fixes <https://issues.guix.gnu.org/52066>. * gnu/packages/make-bootstrap.scm (glibc-for-bootstrap)[native-inputs]: Add gcc-7.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 267adde48c..4ea97368a9 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2018, 2019, 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -86,6 +87,12 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
"--enable-static-nss"
,flags))))
+ ;; Make sure to build glibc with the same compiler version as the rest
+ ;; of the bootstrap. Otherwise it fails to statically link on aarch64.
+ (native-inputs
+ `(("gcc" ,gcc-7)
+ ,@(package-native-inputs base)))
+
;; Remove the 'debug' output to allow bit-reproducible builds (when the
;; 'debug' output is used, ELF files end up with a .gnu_debuglink, which
;; includes a CRC of the corresponding debugging symbols; those symbols