summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-01-10 10:02:44 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-10 10:05:56 +0100
commit4610ab7c9a5327df0d475262817bc081a5891aa8 (patch)
tree034662fdf1c098b8788c5b386f4ad93953adf336 /gnu/packages/make-bootstrap.scm
parentfddb22ac1954a49985b3c0dd5ef253b2c0d35b7c (diff)
downloadguix-patches-4610ab7c9a5327df0d475262817bc081a5891aa8.tar
guix-patches-4610ab7c9a5327df0d475262817bc081a5891aa8.tar.gz
gnu: make-bootstrap: Add libc:static to the inputs.
Fixes use of 'getpwnam' & co. from the statically-linked guile in the initrd, as reported by Leo Famulari <leo@famulari.name> at <https://lists.gnu.org/archive/html/guix-devel/2018-01/msg00061.html>. * gnu/packages/make-bootstrap.scm (package-with-relocatable-glibc)[native-inputs]: Add "libc:static".
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 4b81f73f2e..07ac93686a 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -104,10 +104,12 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
("cross-binutils" ,(cross-binutils target))
,@(%final-inputs)))
`(("libc" ,(glibc-for-bootstrap))
+ ("libc:static" ,(glibc-for-bootstrap) "static")
("gcc" ,(package (inherit gcc)
(outputs '("out")) ; all in one so libgcc_s is easily found
(inputs
`(("libc",(glibc-for-bootstrap))
+ ("libc:static" ,(glibc-for-bootstrap) "static")
,@(package-inputs gcc)))))
,@(fold alist-delete (%final-inputs) '("libc" "gcc")))))