summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-27 19:54:03 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-01 22:06:33 +0200
commit3ba23f0582a432dfc04bfbf58f375f6643caae19 (patch)
treefe139ee830b31683531a843d16e584b1aedc7264 /gnu/packages/make-bootstrap.scm
parente66bbd4201566cdc388f9b02d59da17beb8eb47d (diff)
downloadguix-patches-3ba23f0582a432dfc04bfbf58f375f6643caae19.tar
guix-patches-3ba23f0582a432dfc04bfbf58f375f6643caae19.tar.gz
gnu: Add relocatable static Guile 3.0 variant.
* gnu/packages/patches/guile-2.2-default-utf8.patch: New file, extracted from commit 2acfe022a740f79b593348cc6362cc4ee8f33bb4. * gnu/packages/patches/guile-3.0-linux-syscalls.patch, gnu/packages/patches/guile-3.0-relocatable.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Move all Guile patches together while at it. * gnu/packages/make-bootstrap.scm (%guile-3.0-static-stripped): New public variable.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index d336818299..fe86f810bf 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -55,7 +55,8 @@
%mes-bootstrap-tarball
%bootstrap-tarballs
- %guile-static-stripped))
+ %guile-static-stripped
+ %guile-3.0-static-stripped))
;;; Commentary:
;;;
@@ -797,6 +798,14 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; A stripped static Guile binary, for use during bootstrap.
(make-guile-static-stripped %guile-static))
+(define %guile-3.0-static-stripped
+ ;; A stripped static Guile 3.0 binary, for use in initrds.
+ (make-guile-static-stripped
+ (make-guile-static guile-3.0
+ '("guile-2.2-default-utf8.patch"
+ "guile-3.0-linux-syscalls.patch"
+ "guile-3.0-relocatable.patch"))))
+
(define (tarball-package pkg)
"Return a package containing a tarball of PKG."
(package (inherit pkg)