summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-26 07:39:13 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-26 07:43:36 +0100
commit3342a1182b15ec031f0ec6f602fd96c1dca3d4b0 (patch)
treef9e5b7d8e4baefff7ac635a1e2f94161c4eff896 /gnu/packages/make-bootstrap.scm
parentfef77109370e6bda675297f74ac1073bfe5518ec (diff)
downloadguix-patches-3342a1182b15ec031f0ec6f602fd96c1dca3d4b0.tar
guix-patches-3342a1182b15ec031f0ec6f602fd96c1dca3d4b0.tar.gz
gnu: make-bootstrap: Use _IOLBF on Guile 2.0 only.
* gnu/packages/make-bootstrap.scm (%binutils-static-stripped, %gcc-stripped, %bootstrap-tarballs)[arguments]: Wrap use of '_IOLBF' in 'cond-expand' and use 'line instead on Guile > 2.0.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index f8d782f5ab..b3610afc8e 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -405,7 +405,8 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(begin
(use-modules (guix build utils))
- (setvbuf (current-output-port) _IOLBF)
+ (setvbuf (current-output-port)
+ (cond-expand (guile-2.0 _IOLBF) (else 'line)))
(let* ((in (assoc-ref %build-inputs "binutils"))
(out (assoc-ref %outputs "out"))
(bin (string-append out "/bin")))
@@ -545,7 +546,8 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(srfi srfi-26)
(guix build utils))
- (setvbuf (current-output-port) _IOLBF)
+ (setvbuf (current-output-port)
+ (cond-expand (guile-2.0 _IOLBF) (else 'line)))
(let* ((out (assoc-ref %outputs "out"))
(bindir (string-append out "/bin"))
(libdir (string-append out "/lib"))
@@ -869,7 +871,8 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(ice-9 match)
(srfi srfi-26))
- (setvbuf (current-output-port) _IOLBF)
+ (setvbuf (current-output-port)
+ (cond-expand (guile-2.0 _IOLBF) (else 'line)))
(mkdir out)
(chdir out)
(for-each (match-lambda