summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-25 22:24:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-26 13:24:28 +0200
commit114a9f1f803b53bd295c44b3719c1ed5dd288e40 (patch)
tree3ad5fc3131b8031265e8678faa46bd0ff55837d2 /gnu/packages/make-bootstrap.scm
parent0b9da8b5a2dd9bcb2800d60751eb462e3000fa73 (diff)
downloadguix-patches-114a9f1f803b53bd295c44b3719c1ed5dd288e40.tar
guix-patches-114a9f1f803b53bd295c44b3719c1ed5dd288e40.tar.gz
gnu: mescc-tools: Update to 1.2.0.
Fixes <https://issues.guix.gnu.org/49515>. * gnu/packages/mes.scm (mescc-tools-0.5.2): Remove. (mescc-tools): Update to 1.2.0. Use 'git-fetch'. * gnu/packages/make-bootstrap.scm (%mescc-tools-static): Inherit from MESCC-TOOLS rather than MESCC-TOOLS-0.5.2. (%mes-minimal): Inherit from MES rather than MES-0.19. [arguments]: Remove 'delete-file-recursively' for /mes/scaffold.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 32542f6da7..9f4f5bb4af 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -585,11 +585,11 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(define %mescc-tools-static
;; A statically linked MesCC Tools.
(package
- (inherit mescc-tools-0.5.2)
+ (inherit mescc-tools)
(name "mescc-tools-static")
(arguments
`(#:system "i686-linux"
- ,@(substitute-keyword-arguments (package-arguments mescc-tools-0.5.2)
+ ,@(substitute-keyword-arguments (package-arguments mescc-tools)
((#:make-flags flags)
`(cons "CC=gcc -static" ,flags)))))))
@@ -624,7 +624,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(define-public %mes-minimal
;; A minimal Mes without documentation.
(package
- (inherit mes-0.19)
+ (inherit mes)
(name "mes-minimal")
(native-inputs
`(("guile" ,guile-2.2)))
@@ -641,7 +641,6 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(share (string-append out "/share")))
(delete-file-recursively (string-append out "/lib/guile"))
(delete-file-recursively (string-append share "/guile"))
- (delete-file-recursively (string-append share "/mes/scaffold"))
(for-each delete-file
(find-files