summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-26 13:48:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-26 13:48:06 +0200
commitf589cbc4dc4119e3501a0c20822e72cf841d08f3 (patch)
tree776e10b00c08deb9b5baef64050d512d97468cb8 /gnu/packages/mail.scm
parent0e72d49ef7cb7463012704b3d107fe38b085a562 (diff)
parent2b829898c77c4f5655db6f70de2b3a51e8f35947 (diff)
downloadguix-patches-f589cbc4dc4119e3501a0c20822e72cf841d08f3.tar
guix-patches-f589cbc4dc4119e3501a0c20822e72cf841d08f3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6e2594b07a..589b3e8839 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
+;;; Copyright © 2020 Eric Brown <ecbrown@ericcbrown.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3132,3 +3133,35 @@ related tools to process winmail.dat files.")
complement or replace traditional mailing lists. Readers may read via NNTP,
Atom feeds or HTML archives.")
(license agpl3+))))
+
+(define-public sylpheed
+ (package
+ (name "sylpheed")
+ (version "3.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://sylpheed.sraoss.jp/sylpheed/v3.7/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0j9y5vdzch251s264diw9clrn88dn20bqqkwfmis9l7m8vmwasqd"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("bogofilter" ,bogofilter)
+ ("compface" ,compface)
+ ("gnupg" ,gnupg-1)
+ ("gpgme" ,gpgme)
+ ("gtk+-2.0" ,gtk+-2)
+ ("gtkspell" ,gtkspell3)
+ ("libnsl" ,libnsl)
+ ("openldap" ,openldap)
+ ("openssl" ,openssl)))
+ (home-page "https://sylpheed.sraoss.jp/en/")
+ (synopsis "Lightweight GTK+ email client")
+ (description
+ "Sylpheed is a simple, lightweight but featureful, and easy-to-use e-mail
+client. Sylpheed provides intuitive user-interface. Sylpheed is also
+designed for keyboard-oriented operation.")
+ (license gpl2+)))