summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-07-25 20:37:43 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-07-25 21:26:58 +0200
commitf115d81748d8bedce1344c7e8c1d533ff9a4fe31 (patch)
treee79cf6d69074d98e865bb4d0d3aad523b219016a /gnu/packages/mail.scm
parent1074b37073afd99f59c760ef0e69c59a7b7ec57d (diff)
downloadguix-patches-f115d81748d8bedce1344c7e8c1d533ff9a4fe31.tar
guix-patches-f115d81748d8bedce1344c7e8c1d533ff9a4fe31.tar.gz
gnu: Add perl-mail-authenticationresults.
* gnu/packages/mail.scm (perl-mail-authenticationresults): New variable.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index bfa2394ae4..f783271d18 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2015, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2014 Sou Bunnbu <iyzsong@gmail.com>
-;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2014, 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2015, 2016, 2018 Eric Bavier <bavier@member.fsf.org>
@@ -95,6 +95,7 @@
#:use-module (gnu packages onc-rpc)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages perl-check)
#:use-module (gnu packages perl-web)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -1900,6 +1901,29 @@ Khard can also be used from within the email client @command{mutt}.")
in Perl.")
(license bsd-3)))
+(define-public perl-mail-authenticationresults
+ (package
+ (name "perl-mail-authenticationresults")
+ (version "1.20180923")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MB/MBRADSHAW/"
+ "Mail-AuthenticationResults-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1g1wym9vcbhldwvi4w5pl0fhd4jh2icj975awf4wr5xmkli9mxbz"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)))
+ (home-page "https://metacpan.org/release/Mail-AuthenticationResults")
+ (synopsis "Object Oriented Authentication-Results Headers")
+ (description "Mail::AuthenticationResults parses the message header field
+that indicates the message authentication status as per RFC7601. This module
+is not fully compliant with the RFC but it tries to implement most styles of
+Authentication-Results header seen in the wild.")
+ (license perl-license)))
+
(define-public mb2md
(package
(name "mb2md")