summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
commite3196755e60ba7f1ed9d432e73f26a85e0c8893c (patch)
tree06bc27447f2f72b20a2be0201b41b964af03fc87 /gnu/packages/mail.scm
parentfc9ca46aa6403c90e2ea5c815d813d2dba162dfb (diff)
downloadguix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar
guix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar.gz
gnu: Further simplify package inputs.
This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm28
1 files changed, 11 insertions, 17 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 83e62d46b1..c069e9e928 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -239,10 +239,7 @@ mail client.")
"0dvm6acl32dv8bixx9z50gzwfp6kj4kxnn1j3dcwjlp7sasjp41s"))))
(build-system gnu-build-system)
(native-inputs
- `(("automake" ,automake)
- ("autoconf" ,autoconf)
- ("gettext" ,gettext-minimal)
- ("m4" ,m4))) ;for the test suite
+ (list automake autoconf gettext-minimal m4)) ;for the test suite
(inputs
(list gdbm
gnutls
@@ -1524,10 +1521,7 @@ and search library.")
(native-inputs
(list pandoc pkg-config))
(inputs
- `(("libcrypto" ,openssl)
- ("notmuch" ,notmuch)
- ("sqlite" ,sqlite)
- ("xapian" ,xapian)))
+ (list openssl notmuch sqlite xapian))
(home-page "http://www.muchsync.org/")
(synopsis "Synchronize notmuch mail across machines")
(description
@@ -4136,15 +4130,15 @@ IMAP, Atom feeds or HTML archives.")
(native-inputs
(list pkg-config))
(inputs
- `(("bogofilter" ,bogofilter)
- ("compface" ,compface)
- ("gnupg" ,gnupg-1)
- ("gpgme" ,gpgme)
- ("gtk+-2.0" ,gtk+-2)
- ("gtkspell" ,gtkspell3)
- ("libnsl" ,libnsl)
- ("openldap" ,openldap)
- ("openssl" ,openssl)))
+ (list bogofilter
+ compface
+ gnupg-1
+ gpgme
+ gtk+-2
+ gtkspell3
+ libnsl
+ openldap
+ openssl))
(home-page "https://sylpheed.sraoss.jp/en/")
(synopsis "Lightweight GTK+ email client")
(description