summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-08 15:53:41 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-09 20:37:06 +0200
commitdb0109be42547d5dbb0fc1eb8ae30ccc968ed88b (patch)
tree9819b441e10396133672ab022f298150b40b27fb /gnu/packages/mail.scm
parent042d7eb114b9fc7e8559705dd6eaebb06f5977fc (diff)
downloadguix-patches-db0109be42547d5dbb0fc1eb8ae30ccc968ed88b.tar
guix-patches-db0109be42547d5dbb0fc1eb8ae30ccc968ed88b.tar.gz
gnu: dovecot: Set moduledir to global directory.
* gnu/packages/mail.scm (dovecot)[arguments]: Add configure-flag to set moduledir. Adjust custom 'install phase to override moduledir so it successfully installs. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6f3a967575..7af7e8a8d7 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1453,6 +1453,7 @@ facilities for checking incoming mail.")
(arguments
`(#:configure-flags '("--sysconfdir=/etc"
"--localstatedir=/var"
+ "--with-moduledir=/etc/dovecot/modules"
"--with-sqlite" ; not auto-detected
"--with-lucene") ; not auto-detected
#:phases
@@ -1471,9 +1472,13 @@ facilities for checking incoming mail.")
(("cat") (which "cat")))
#t))
(replace 'install
- (lambda* (#:key make-flags #:allow-other-keys)
+ (lambda* (#:key outputs make-flags #:allow-other-keys)
+ ;; The .la files don't like having the moduledir moved.
+ (for-each delete-file (find-files "." "\\.la"))
;; Simple hack to avoid installing a trivial README in /etc.
(apply invoke "make" "install" "sysconfdir=/tmp/bogus"
+ (string-append "moduledir=" (assoc-ref outputs "out")
+ "/lib/dovecot")
make-flags))))))
(home-page "https://www.dovecot.org")
(synopsis "Secure POP3/IMAP server")