summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-07 18:56:48 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-08 02:26:17 +0100
commitc9b99e88f510a4211df2be56f2c13d380f7a99b2 (patch)
treeb08deb5790842b1f11bf2109460f5a60ac1cf559 /gnu/packages/mail.scm
parentcda8250b204c5b59211064e94e068766c2613456 (diff)
downloadguix-patches-c9b99e88f510a4211df2be56f2c13d380f7a99b2.tar
guix-patches-c9b99e88f510a4211df2be56f2c13d380f7a99b2.tar.gz
gnu: exim: Use XZ-compressed sources.
* gnu/packages/mail.scm (exim)[source]: Fetch the .tar.xz archive.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a674837ce8..30623d786b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1264,16 +1264,17 @@ delivery.")
(source
(origin
(method url-fetch)
- (uri (list (string-append "https://ftp.exim.org/pub/exim/exim4/exim-"
- version ".tar.bz2")
- ;; ‘Fix’ releases (exim-x.y.z.f) are kept separately.
- (string-append "https://ftp.exim.org/pub/exim/exim4/fixes/exim-"
- version ".tar.bz2")
- ;; After a new release the previous one is moved here.
- (string-append "https://ftp.exim.org/pub/exim/exim4/old/exim-"
- version ".tar.bz2")))
+ (uri (let ((file-name (string-append "exim-" version ".tar.xz")))
+ (list (string-append "https://ftp.exim.org/pub/exim/exim4/"
+ file-name)
+ ;; ‘Fix’ releases (exim-x.y.z.f) are kept separately.
+ (string-append "https://ftp.exim.org/pub/exim/exim4/fixes/"
+ file-name)
+ ;; After a new non-fix release, the old one is moved here.
+ (string-append "https://ftp.exim.org/pub/exim/exim4/old/"
+ file-name))))
(sha256
- (base32 "1ng4flyv2jqjbw66dbdgma7kfnnph9h3s1yyc0q27n7q0sx3cwxn"))))
+ (base32 "01g4sfycv13glnmfrapwhjbdw6z1z7w5bwjldxjmglwfw5p3czak"))))
(build-system gnu-build-system)
(inputs
`(("bdb" ,bdb-5.3) ; ‘#error Version 6 and later BDB API is not supported’