summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 15:26:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 15:30:10 +0300
commita3bdebefab867fdbc29f4b8a2ca78b24a6f23557 (patch)
tree206712eb04c931c5a01b8a1abc771635822e251c /gnu/packages/mail.scm
parentb0c8358f84605a21a3f30cc404190f25d437c0bf (diff)
downloadguix-patches-a3bdebefab867fdbc29f4b8a2ca78b24a6f23557.tar
guix-patches-a3bdebefab867fdbc29f4b8a2ca78b24a6f23557.tar.gz
gnu: Add python-mailman-hyperkitty.
* gnu/packages/mail.scm (python-mailman-hyperkitty): New variable.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index ba6625749a..aff9c74c28 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2695,6 +2695,46 @@ interacting with Mailman.")
interacting with Mailman.")
(license license:gpl3+)))
+(define-public python-mailman-hyperkitty
+ (package
+ (name "python-mailman-hyperkitty")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mailman-hyperkitty" version))
+ (sha256
+ (base32
+ "1lfqa9admhvdv71f528jmz2wl0i5cv77v6l64px2pm4zqr9ckkjx"))
+ (patches
+ (list
+ (origin
+ ;; see: https://gitlab.com/mailman/mailman-hyperkitty/issues/17
+ ;; fixes test_archive_message_unserializable
+ (method url-fetch)
+ (uri "https://salsa.debian.org/mailman-team/mailman-hyperkitty/raw/debian/1.1.0-9/debian/patches/0002-Skip-the-test_archive_message_unserializable.patch")
+ (sha256
+ (base32
+ "0p1fwm46c4bl81lvsg3kjhn2r1lwgkpgxamb3xyqn7h9qdrw10hw")))))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-requests" ,python-requests)
+ ("python-zope-interface" ,python-zope-interface)))
+ (inputs
+ `(("mailman" ,mailman)))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)
+ ("python-nose2" ,python-nose2)))
+ (home-page "https://gitlab.com/mailman/mailman-hyperkitty/")
+ (synopsis "Mailman archiver plugin for HyperKitty")
+ (description
+ "Mailman3 allows emails sent to its mailing lists to be archived by any
+software provided that there is a plugin (loadable by Mailman3) designed to
+communicate with it properly. This module contains a Mailman3 archiver plugin
+which sends emails to HyperKitty, the official Mailman3 web archiver.")
+ (license license:gpl3+)))
+
(define-public postorius
(package
(name "postorius")