summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 10:20:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 10:20:56 +0300
commit99d48f7a2ccee277ecd5e5bd57179e6c8e8fdfa0 (patch)
treef508fb4bbc7a3a35ad2c271f4ffd452c9c81ed4e /gnu/packages/mail.scm
parenta8f9b9380d9e3c3e77abaa1c7aecd0fb577c6add (diff)
downloadguix-patches-99d48f7a2ccee277ecd5e5bd57179e6c8e8fdfa0.tar
guix-patches-99d48f7a2ccee277ecd5e5bd57179e6c8e8fdfa0.tar.gz
gnu: Add python-authres.
* gnu/packages/mail.scm (python-authres): New variable.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 8b7a2bc00a..66e579946e 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3199,3 +3199,42 @@ Atom feeds or HTML archives.")
client. Sylpheed provides intuitive user-interface. Sylpheed is also
designed for keyboard-oriented operation.")
(license license:gpl2+)))
+
+(define-public python-authres
+ (package
+ (name "python-authres")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "authres" version))
+ (sha256
+ (base32
+ "1dr5zpqnb54h4f5ax8334l1dcp8j9083d7v4vdi1xqkwmnavklck"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ ;; Run doctests as described in the README.
+ (lambda _
+ (invoke "python" "-m" "authres" "-v"))))))
+ (home-page "https://launchpad.net/authentication-results-python")
+ (synopsis "Email Authentication Results Header Module")
+ (description
+ "This module can be used to generate and parse RFC 5451/7001/7601
+Authentication-Results headers. It also supports Authentication Results
+extensions:
+@itemize
+@item RFC 5617 DKIM/ADSP
+@item RFC 6008 DKIM signature identification (header.b)
+@item RFC 6212 Vouch By Reference (VBR)
+@item RFC 6577 Sender Policy Framework (SPF)
+@item RFC 7281 Authentication-Results Registration for S/MIME
+@item RFC 7293 The Require-Recipient-Valid-Since Header Field
+@item RFC 7489 Domain-based Message Authentication, Reporting, and Conformance (DMARC)
+@item Authenticated Recieved Chain (ARC) (draft-ietf-dmarc-arc-protocol-08)
+@end itemize
+Note: RFC 7601 obsoletes RFC 5451, 6577, 7001, and 7410. Authres supports the
+current standard. No backward compatibility issues have been noted.")
+ (license license:asl2.0)))