summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-08 15:37:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-08 15:43:07 -0400
commit838c4b10e9905e1957a57a281152599c1cdd17ce (patch)
tree116637c26ca5e60975ac419b6c779b3240a739ec /gnu/packages/mail.scm
parent933abfba365b03a146b1898d9e785e0daf3ee317 (diff)
downloadguix-patches-838c4b10e9905e1957a57a281152599c1cdd17ce.tar
guix-patches-838c4b10e9905e1957a57a281152599c1cdd17ce.tar.gz
gnu: opensmtpd: Patch bug in 'smtpctl encrypt'.
* gnu/packages/mail.scm (opensmtpd)[phases]{fix-smtpctl-encrypt-bug}: New phase.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 8337bc7808..0c683f0c92 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2322,6 +2322,13 @@ transfer protocols.")
"--with-table-db")
#:phases
(modify-phases %standard-phases
+ ;; See: https://github.com/OpenSMTPD/OpenSMTPD/issues/1069.
+ (add-after 'unpack 'fix-smtpctl-encrypt-bug
+ (lambda _
+ (substitute* "smtpd/smtpctl.c"
+ (("\"encrypt\", \"--\",")
+ "\"encrypt\","))
+ #t))
;; Fix some incorrectly hard-coded external tool file names.
(add-after 'unpack 'patch-FHS-file-names
(lambda _