summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-19 02:33:07 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-19 04:24:25 +0200
commit525304e1b94c70abdb6a8ee4c836f110e6ab9930 (patch)
tree3e005842131c95c6322741627a04c04dafe74cae /gnu/packages/mail.scm
parentbf2727c1b4ac2b4dc853a08933fb3ac4de6994dc (diff)
downloadguix-patches-525304e1b94c70abdb6a8ee4c836f110e6ab9930.tar
guix-patches-525304e1b94c70abdb6a8ee4c836f110e6ab9930.tar.gz
gnu: python-aiosmtpd: Update to 1.2.1.
* gnu/packages/mail.scm (python-aiosmtpd): Update to 1.2.1. [source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 29c5be7417..e3211690e1 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3517,20 +3517,23 @@ DKIM and ARC sign messages and output the corresponding signature headers.")
(define-public python-aiosmtpd
(package
(name "python-aiosmtpd")
- (version "1.2")
+ (version "1.2.1")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "aiosmtpd" version))
- (sha256
- (base32
- "1xdfk741pjmz1cm8dsi4n5vq4517i175rm94696m3f7kcgk7xsmp"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aio-libs/aiosmtpd")
+ (commit version)))
+ (sha256
+ (base32 "14c30dm6jzxiblnsah53fdv68vqhxwvb9x0aq9bc4vcdas747vr7"))
+ (file-name (git-file-name name version))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'delete-failing-test
+ (add-after 'unpack 'delete-failing-tests
(lambda _
+ ;; This test uses an expired certificate.
(delete-file "aiosmtpd/tests/test_smtps.py")
#t))
(replace 'check