summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-05 13:46:44 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-17 14:28:11 -0400
commit19ca98286191e5990c3973f882144cc568a956ff (patch)
tree241b110b914af987cc975ac84c6812c035b1bf61 /gnu/packages/mail.scm
parent3b3e392196c5b43c929410fa0b8f9c23c5b62544 (diff)
downloadguix-patches-19ca98286191e5990c3973f882144cc568a956ff.tar
guix-patches-19ca98286191e5990c3973f882144cc568a956ff.tar.gz
gnu: Add anubis.
* gnu/packages/mail.scm (anubis): New variable.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index ec1233f83b..e89a6f330f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
;;; Copyright © 2020 Eric Brown <ecbrown@ericcbrown.com>
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -146,6 +147,44 @@
#:use-module (srfi srfi-1)
#:use-module (ice-9 match))
+(define-public anubis
+ (package
+ (name "anubis")
+ ;; This 4.2.90 alpha release adds support for Guile 3 and has fixes for
+ ;; other issues.
+ (version "4.2.90")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://alpha.gnu.org/gnu/anubis/anubis-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0dvm6acl32dv8bixx9z50gzwfp6kj4kxnn1j3dcwjlp7sasjp41s"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("gettext" ,gettext-minimal)
+ ("m4" ,m4))) ;for the test suite
+ (inputs
+ `(("gdbm" ,gdbm)
+ ("gnutls" ,gnutls)
+ ("gpgme" ,gpgme)
+ ("gsasl" ,gsasl)
+ ("guile" ,guile-3.0)
+ ("libgcrypt" ,libgcrypt) ;gnutls support depends on libgcrypt
+ ("libgpg-error" ,libgpg-error)))
+ (outputs '("out" "debug"))
+ (synopsis "SMTP message submission daemon")
+ (description "Anubis is a daemon that sits between the Mail User
+Agent (MUA) and the Mail Transfer Agent (MTA). When a mail is sent by a user
+in the MUA, it is first passed to Anubis, which performs additional processing
+to the message before passing it on for delivery by the MTA. Anubis may, for
+example, modify the message headers or body, or encrypt or sign the message.")
+ (home-page "https://www.gnu.org/software/anubis/manual/")
+ (license gpl3+)))
+
(define-public mailutils
(package
(name "mailutils")