summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-05 23:38:27 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 05:24:17 +0100
commit1326b360739293b9be7185acce9b6cc26a6d498d (patch)
tree4c69ff568a3c5c20cab5f3922237af77455e4c4b /gnu/packages/mail.scm
parent0d78ac083a9095ae82e3c27f19e67691bcad41d1 (diff)
downloadguix-patches-1326b360739293b9be7185acce9b6cc26a6d498d.tar
guix-patches-1326b360739293b9be7185acce9b6cc26a6d498d.tar.gz
gnu: pan: Use G-expressions.
* gnu/packages/mail.scm (pan)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 8383a677f7..b426d5f4da 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -62,6 +62,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages mail)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
@@ -3789,17 +3790,19 @@ killed threads.")
(sha256
(base32 "1sl5rdgalswxya61vhkf28r0fb4b3pq77qgzhhsfagmpvgbx0d2x"))))
(arguments
- `(#:configure-flags '("--with-gtk3" "--with-gtkspell" "--with-gnutls"
- "--enable-libnotify" "--enable-manual"
- "--enable-gkr")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-gpg2
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "pan/usenet-utils/gpg.cc"
- (("\"gpg2\"") (string-append "\""
- (assoc-ref inputs "gnupg")
- "/bin/gpg\""))))))))
+ (list #:configure-flags
+ #~(list "--with-gtk3" "--with-gtkspell" "--with-gnutls"
+ "--enable-libnotify" "--enable-manual"
+ "--enable-gkr")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'patch-gpg2
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "pan/usenet-utils/gpg.cc"
+ (("\"gpg2\"")
+ (string-append "\""
+ (search-input-file inputs "/bin/gpg")
+ "\""))))))))
(inputs
(list gmime
gnupg