summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-05-16 16:08:32 +0200
committerMarius Bakke <marius@gnu.org>2021-05-23 17:49:57 +0200
commit030bdbf141eefa725735d4fe04e2ef5763a14f24 (patch)
treeaeeaea14ce397fca2432357fa21b1b239fa7b06c /gnu/packages/mail.scm
parenta9f84f93b45db712b3bd30943361a267cb85cf79 (diff)
downloadguix-patches-030bdbf141eefa725735d4fe04e2ef5763a14f24.tar
guix-patches-030bdbf141eefa725735d4fe04e2ef5763a14f24.tar.gz
gnu: notmuch: Update to 0.32.1.
* gnu/packages/mail.scm (notmuch): Update to 0.32.1. [arguments]<#:phases>: Don’t return #t at the end of the phase, this won’t be necessary once core-update gets merged. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 8cb233812f..ded60cdc2c 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1331,14 +1331,14 @@ invoking @command{notifymuch} from the post-new hook.")
(define-public notmuch
(package
(name "notmuch")
- (version "0.31.4")
+ (version "0.32.1")
(source (origin
(method url-fetch)
(uri (string-append "https://notmuchmail.org/releases/notmuch-"
version ".tar.xz"))
(sha256
(base32
- "0magnyjjhhv11nwcm2596hdxszrj61y69i0hmwqdc3v6cxjvcqc6"))))
+ "0586d13ssygapjdri4cl25wzywivwsbxpjm6xlgxj6f9ii7clix7"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -1354,8 +1354,7 @@ invoking @command{notifymuch} from the post-new hook.")
(add-after 'unpack 'patch-notmuch-lib.el
(lambda _
(substitute* "emacs/notmuch-lib.el"
- (("/bin/sh") (which "sh")))
- #t))
+ (("/bin/sh") (which "sh")))))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(setenv "CC" "gcc")
@@ -1372,15 +1371,13 @@ invoking @command{notifymuch} from the post-new hook.")
;; and try removing this for notmuch versions > 0.31.
(lambda _
(substitute* "test/T356-protected-headers.sh"
- (("\\$NOTMUCH_GMIME_X509_CERT_VALIDITY") "0"))
- #t))
+ (("\\$NOTMUCH_GMIME_X509_CERT_VALIDITY") "0"))))
(add-before 'check 'prepare-test-environment
(lambda _
(setenv "TEST_CC" "gcc")
;; Patch various inline shell invocations.
(substitute* (find-files "test" "\\.sh$")
- (("/bin/sh") (which "sh")))
- #t))
+ (("/bin/sh") (which "sh")))))
(add-after 'install 'make-autoloads
(assoc-ref emacs:%standard-phases 'make-autoloads)))))
(native-inputs