summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-07-07 12:08:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-07 14:02:33 +0200
commitdeae5d0df1f66250ed6b06f15b7526ee4a44632a (patch)
tree3f0bb4c3eba41877d931111af014fcb7af6ea429 /gnu/packages/machine-learning.scm
parent87b43ab56214a4fee33814117212df6cfc64f5c0 (diff)
downloadguix-patches-deae5d0df1f66250ed6b06f15b7526ee4a44632a.tar
guix-patches-deae5d0df1f66250ed6b06f15b7526ee4a44632a.tar.gz
gnu: python-pytorch: Update to 1.12.0.
* gnu/packages/machine-learning.scm (python-pytorch): Update to 1.12.0. [arguments]: Explicitly request the use of our pybind11 package.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index a901311702..fa5f5a9581 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -2870,7 +2870,7 @@ TensorFlow.js, PyTorch, and MediaPipe.")
(define-public python-pytorch
(package
(name "python-pytorch")
- (version "1.11.0")
+ (version "1.12.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2880,7 +2880,7 @@ TensorFlow.js, PyTorch, and MediaPipe.")
(file-name (git-file-name name version))
(sha256
(base32
- "1zbk7y74r0ycsfa7x59jnhwhs1gj5rs3n89p15y0212iszgbljq8"))
+ "0pdqi91qzgyx947zv4pw2fdj9vpqvdhfzw1ydjd4mpqm8g5njgnz"))
(patches (search-patches "python-pytorch-system-libraries.patch"
"python-pytorch-runpath.patch"))
(modules '((guix build utils)))
@@ -2911,6 +2911,10 @@ TensorFlow.js, PyTorch, and MediaPipe.")
;; ones.
(setenv "USE_SYSTEM_LIBS" "1")
+ (substitute* "cmake/Dependencies.cmake"
+ (("if\\(USE_SYSTEM_BIND11\\)")
+ "if(TRUE)"))
+
;; XXX: Disable that for simplicity for now.
(setenv "USE_FBGEMM" "0")))
(add-before 'build 'make-things-writable