summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-09-24 13:46:02 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-24 13:48:50 +0200
commitd326dec8115cf5e2cac9497633dc11ecc970361b (patch)
treecb38b50c3dbfbbc8660808692fc8fdc17b8dc33e /gnu/packages/machine-learning.scm
parent8df301d467f65f71d60532f435570949d71e0274 (diff)
downloadguix-patches-d326dec8115cf5e2cac9497633dc11ecc970361b.tar
guix-patches-d326dec8115cf5e2cac9497633dc11ecc970361b.tar.gz
gnu: python-pytorch: Unbundle NNPACK.
* gnu/packages/machine-learning.scm (python-pytorch)[source]: Delete "third_party/NNPACK". [inputs]: Add NNPACK. [propagated-inputs]: Remove PYTHON-PEACHPY. * gnu/packages/patches/python-pytorch-system-libraries.patch: Remove hunk modifying NNPACK; add hunk to allow the use of our own NNPACK.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index a8e2a40ed6..9b5d4c1743 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -2668,7 +2668,7 @@ TensorFlow.js, PyTorch, and MediaPipe.")
;; needs these.
;; "FP16" "FXdiv" "gemmlowp" "psimd"
- "gloo" "googletest" "ios-cmake"
+ "gloo" "googletest" "ios-cmake" "NNPACK"
"onnx" "protobuf" "pthreadpool"
"pybind11" "python-enum" "python-peachpy"
"python-six" "tbb" "XNNPACK" "zstd"))
@@ -2733,6 +2733,7 @@ TensorFlow.js, PyTorch, and MediaPipe.")
("googletest" ,googletest)
("googlebenchmark" ,googlebenchmark)
("gloo" ,gloo)
+ ("nnpack" ,nnpack)
("openblas" ,openblas)
("openmpi" ,openmpi)
("pthreadpool" ,pthreadpool)
@@ -2746,7 +2747,6 @@ TensorFlow.js, PyTorch, and MediaPipe.")
("python-numpy" ,python-numpy)
("python-pyyaml" ,python-pyyaml)
("python-cffi" ,python-cffi)
- ("python-peachpy" ,python-peachpy)
("python-typing-extensions" ,python-typing-extensions)
("python-future" ,python-future)
("python-six" ,python-six)