summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-08-03 15:54:26 +0200
committerLudovic Courtès <ludo@gnu.org>2021-08-04 17:22:19 +0200
commitc83d7d68f324e5c70c0b7ec8de4fff2deee792ca (patch)
tree48ff7a54d769bfa36e7552300bc2eeb87712b2cb /gnu/packages/machine-learning.scm
parent36f7e1d78389f1d8d68fabda729b1ca95369bda3 (diff)
downloadguix-patches-c83d7d68f324e5c70c0b7ec8de4fff2deee792ca.tar
guix-patches-c83d7d68f324e5c70c0b7ec8de4fff2deee792ca.tar.gz
gnu: gloo: Honor #:tests? in 'check' phase.
* gnu/packages/machine-learning.scm (gloo)[arguments]: In 'check' phase, honor #:tests?.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 89bde8396c..857a71ce15 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -2462,9 +2462,9 @@ that:
#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "make" "gloo_test")
- #t)))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "gloo_test")))))))
(synopsis "Collective communications library")
(description
"Gloo is a collective communications library. It comes with a