summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-17 22:07:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-17 22:36:26 +0100
commitbe6eb2f1e6f77d3cff3bdaef12fdc4c26c806b92 (patch)
tree39cce34b4d6e75c3bc4366ed95719c7261554c19 /gnu/packages/machine-learning.scm
parent98c6a02573c6d568cfa830526dca15e6789d0646 (diff)
downloadguix-patches-be6eb2f1e6f77d3cff3bdaef12fdc4c26c806b92.tar
guix-patches-be6eb2f1e6f77d3cff3bdaef12fdc4c26c806b92.tar.gz
gnu: python-scikit-learn: Move from python.scm to machine-learning.scm.
* gnu/packages/python.scm (python-scikit-learn, python2-scikit-learn): Move from here... * gnu/packages/machine-learning.scm: ...to here.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm56
1 files changed, 54 insertions, 2 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 8cd01062fd..a32ea36e6c 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1,7 +1,8 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,10 +28,12 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system ocaml)
+ #:use-module (guix build-system python)
#:use-module (guix build-system r)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages cran)
#:use-module (gnu packages dejagnu)
@@ -604,3 +607,52 @@ including robotics, embedded devices, mobile phones, and large high performance
computing environments.")
(home-page "http://dlib.net")
(license license:boost1.0)))
+
+(define-public python-scikit-learn
+ (package
+ (name "python-scikit-learn")
+ (version "0.19.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/scikit-learn/scikit-learn/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0g7q4ri75mj93wpa9bp83a3jmrf3dm5va9h7k4zkbcxr6bgqka15"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ ;; Running tests from the source directory requires
+ ;; an "inplace" build with paths relative to CWD.
+ ;; http://scikit-learn.org/stable/developers/advanced_installation.html#testing
+ ;; Use the installed version instead.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ ;; some tests require access to "$HOME"
+ (setenv "HOME" "/tmp")
+ ;; Step out of the source directory just to be sure.
+ (chdir "..")
+ (zero? (system* "nosetests" "-v" "sklearn")))))))
+ (inputs
+ `(("openblas" ,openblas)))
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-cython" ,python-cython)))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-scipy" ,python-scipy)))
+ (home-page "http://scikit-learn.org/")
+ (synopsis "Machine Learning in Python")
+ (description
+ "Scikit-learn provides simple and efficient tools for data
+mining and data analysis.")
+ (license license:bsd-3)))
+
+(define-public python2-scikit-learn
+ (package-with-python2 python-scikit-learn))