summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorMark Meyer <mark@ofosos.org>2018-02-01 15:07:58 +0100
committerBen Woodcroft <donttrustben@gmail.com>2018-02-02 23:04:46 +1000
commita9b34762391e6f3b066aef6fc1ebc614ec88db86 (patch)
treea226446ee56ba41dc1c40294f69554918f3d6c88 /gnu/packages/machine-learning.scm
parent9b94ced45c37ec1ccd25dd1f232989d2bd90e95b (diff)
downloadguix-patches-a9b34762391e6f3b066aef6fc1ebc614ec88db86.tar
guix-patches-a9b34762391e6f3b066aef6fc1ebc614ec88db86.tar.gz
gnu: Add fann.
* gnu/packages/machine-learning.scm (fann): New variable. Co-authored-by: Ben Woodcroft <donttrustben@gmail.com>
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index bd13cedcb3..93d6027250 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -4,6 +4,8 @@
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Mark Meyer <mark@ofosos.org>
+;;; Copyright © 2018 Ben Woodcroft <donttrustben@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +33,7 @@
#:use-module (guix build-system ocaml)
#:use-module (guix build-system python)
#:use-module (guix build-system r)
+ #:use-module (guix git-download)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
@@ -50,6 +53,38 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public fann
+ ;; The last release is >100 commits behind, so we package from git.
+ (let ((commit "d71d54788bee56ba4cf7522801270152da5209d7"))
+ (package
+ (name "fann")
+ (version (string-append "2.2.0-1." (string-take commit 8)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libfann/fann.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0ibwpfrjs6q2lijs8slxjgzb2llcl6rk3v2ski4r6215g5jjhg3x"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (with-directory-excursion (string-append (getcwd) "/tests")
+ (invoke "./fann_tests"))))))))
+ (home-page "http://leenissen.dk/fann/wp/")
+ (synopsis "Fast Artificial Neural Network")
+ (description
+ "FANN is a free open source neural network library, which implements
+multilayer artificial neural networks in C with support for both fully
+connected and sparsely connected networks.")
+ (license license:lgpl2.1))))
+
(define-public libsvm
(package
(name "libsvm")